Unhandled Exception when models are added

broken avatar :(
Created 1593 days ago
by Psych
0 Members and 1 Guest are viewing this topic.
3,186 views
broken avatar :(
×
broken avatar :(
Location: usunited states
Date Registered: 19 August 2012
Last active: 513 days ago
Posts
215
Respect
Forum Rank
Mr. Elemental
Primary Group
Member
Personal Quote
Mapper
Signature
Maker of Contrivance
×
Psych's Groups
Psych's Contact & Social Links
So I have avoided this error a few times now but it appears I finally have to get some help about it. Recently I implemented my Easter egg in Contrivance but now I get a crash at launch due to an Unhandled exception being caught. Now I have received this error before actually fairly recently when I tried to add the clutter_lilypad xmodel into my map... Deleting the lilypads solved the issue but this was an odd thing to cause the error in my opinion. I thought it was the model limit or possibly the memory limit but it is definitely neither so now I am kind of stuck as I need to add new models into my map for the Easter egg. Anyone ever experience this? Have seen a few posts with no solutions and barely any replies so I am hoping this is the one to resolve it.

Just a note developer 1 and such returns errors that do not make sense they are unrelated and do not help at all.

Thanks!
This topic contains a post which is marked as the Best Answer. Click here to view it.
broken avatar :(
×
broken avatar :(
Location: nlApeldoorn
Date Registered: 17 December 2013
Last active: 27 days ago
Posts
1,187
Respect
1,393Add +1
Forum Rank
Zombie Colossus
Primary Group
Community Scripter Elite
My Groups
More
My Contact & Social Links
More
Personal Quote
It aint much, if it aint Dutch
Signature
[RELEASED] Greenhouse Realism 3.0: [You are not allowed to view external links. Register or Login to see them]

NUK370WN Realism 3.0: [You are not allowed to view external links. Register or Login to see them]
Industrial Estate Realism 3.0: [You are not allowed to view external links. Register or Login to see them]

Support my work here:  [You are not allowed to view external links. Register or Login to see them]
×
BluntStuffy's Groups
Donator ♥ Benevolent Soul who has our eternal gratitude and exclusive access to betas and the donator section of the forum.
Community Scripter Elite Has shown excellence and experience in the area of custom scripting in the UGX-Mods community.
Oil Rig Beta Access
Oil Rig Beta Access
BluntStuffy's Contact & Social LinksBluntstuffy@BluntZombieBluntStuffyStuffyZombie
... I thought it was the model limit or possibly the memory limit but it is definitely neither...

Are you sure, because it useally is. Either that or a corrupt model maybe.
You could open the console and type 'meminfo' to see if you're anywhere near


Quote
Just a note developer 1 and such returns errors that do not make sense they are unrelated and do not help at all.

Because the error that is causing the unhandled exception occurs at the end of loading the map, and these 'unrelated' errors are preventing it from even getting that far. An error is an error, the console isn't making those up. If you want the error for the unhandled execption to show up ( if there's any ) you would need to fix all other stuff first so it would run in developer mode
broken avatar :(
×
broken avatar :(
Location: usunited states
Date Registered: 19 August 2012
Last active: 513 days ago
Posts
215
Respect
Forum Rank
Mr. Elemental
Primary Group
Member
Personal Quote
Mapper
×
Psych's Groups
Psych's Contact & Social Links
Are you sure, because it useally is. Either that or a corrupt model maybe.
You could open the console and type 'meminfo' to see if you're anywhere near


Because the error that is causing the unhandled exception occurs at the end of loading the map, and these 'unrelated' errors are preventing it from even getting that far. An error is an error, the console isn't making those up. If you want the error for the unhandled execption to show up ( if there's any ) you would need to fix all other stuff first so it would run in developer mode

Well I have concluded that the error is caused by new models being entered into the map for sure and once I remove them it runs fine. The issue with DEV mode only happens when the models are added not when they are removed. The error it gives is also in a file that simply does not exist which would seem to be impossible but I am looking right at it now. It calls an error from my _loadout.gsc in my mod/mapname/maps folder despite it not even being there which makes no sense at all which is why I am so confused. Even when I add it there and resolve the error it claims to have with the script it still shows the same error on the same line somehow. I have no idea what to do at this point I have tried to resolve it all day and have gotten nowhere not sure what else I can even try
broken avatar :(
×
broken avatar :(
Location: nlApeldoorn
Date Registered: 17 December 2013
Last active: 27 days ago
Posts
1,187
Respect
1,393Add +1
Forum Rank
Zombie Colossus
Primary Group
Community Scripter Elite
My Groups
More
My Contact & Social Links
More
Personal Quote
It aint much, if it aint Dutch
×
BluntStuffy's Groups
Donator ♥ Benevolent Soul who has our eternal gratitude and exclusive access to betas and the donator section of the forum.
Community Scripter Elite Has shown excellence and experience in the area of custom scripting in the UGX-Mods community.
Oil Rig Beta Access
Oil Rig Beta Access
BluntStuffy's Contact & Social LinksBluntstuffy@BluntZombieBluntStuffyStuffyZombie
Quote
It calls an error from my _loadout.gsc in my mod/mapname/maps folder despite it not even being there which makes no sense at all which is why I am so confused. Even when I add it there and resolve the error it claims to have with the script it still shows the same error on the same line somehow.

_loadout is compiled into any map, it just grabs the one from raw when compiling if it's not in your mod. What's the error?
broken avatar :(
×
broken avatar :(
Location: usunited states
Date Registered: 19 August 2012
Last active: 513 days ago
Posts
215
Respect
Forum Rank
Mr. Elemental
Primary Group
Member
Personal Quote
Mapper
×
Psych's Groups
Psych's Contact & Social Links
_loadout is compiled into any map, it just grabs the one from raw when compiling if it's not in your mod. What's the error?

oops my bad I did not mean my mod folder. I mean I actually removed it from maps and even after a full recompile it still called the same error from it somehow even though it didnt exsist in maps anymore lol. But anyways here is the error:

I actually commented out those lines and it somehow still called the same error on the same line  :o


broken avatar :(
×
broken avatar :(
Location: nlApeldoorn
Date Registered: 17 December 2013
Last active: 27 days ago
Posts
1,187
Respect
1,393Add +1
Forum Rank
Zombie Colossus
Primary Group
Community Scripter Elite
My Groups
More
My Contact & Social Links
More
Personal Quote
It aint much, if it aint Dutch
×
BluntStuffy's Groups
Donator ♥ Benevolent Soul who has our eternal gratitude and exclusive access to betas and the donator section of the forum.
Community Scripter Elite Has shown excellence and experience in the area of custom scripting in the UGX-Mods community.
Oil Rig Beta Access
Oil Rig Beta Access
BluntStuffy's Contact & Social LinksBluntstuffy@BluntZombieBluntStuffyStuffyZombie
copy it into mods\mapname\maps\ and comment out only line 42.
_loadout is compiled into your mapname_patch, so if you havent recompiled that it still grabs the old version from there. Add it to your mod and edit it to fix the error, then it overwrite's the one that's in your _patch
broken avatar :(
×
broken avatar :(
☭ Soviet Commander ☭
Location: us
Date Registered: 13 August 2012
Last active: 1551 days ago
Posts
2,794
Respect
Forum Rank
King of the Zombies
Primary Group
Community Daedra
My Groups
More
My Contact & Social Links
More
Signature
Let's keep this thread on topic from here on in. -DBZ

+1 to off-topic reply -DBZ

lmao. Too funny.

Goliath Script Placer: http://ugx-mods.com/forum/index.php/topic,11234.msg125257/topicseen.html#new

"...Christ, people. Learn C, instead of just stringing random characters
together until it compiles (with warnings)..."

-Linus Torvalds
×
daedra descent's Groups
Community Daedra
Community Daedra
daedra descent's Contact & Social LinksBlueSoviet
If your not doing anything with the model(s) via script then developer(and developer_script) probably isn't going to help you. Its the engine itself thats throwing the unhandled exception, not the GSC compiler.
Marked as best answer by Psych on Today at 07:26:18 am
broken avatar :(
×
broken avatar :(
Location: usunited states
Date Registered: 19 August 2012
Last active: 513 days ago
Posts
215
Respect
Forum Rank
Mr. Elemental
Primary Group
Member
Personal Quote
Mapper
×
Psych's Groups
Psych's Contact & Social Links
If your not doing anything with the model(s) via script then developer(and developer_script) probably isn't going to help you. Its the engine itself thats throwing the unhandled exception, not the GSC compiler.

Yeah that makes sense and you know a lot more about the engine than I do so would there be any reason for this? Seems kind of odd that adding a model, something I have done a hundred times before into the map, would cause this sort of error all of the sudden? Oh and no they are not even script_models they are just normal xmodels so idfk

Double Post Merge: May 15, 2016, 07:57:43 pm
copy it into mods\mapname\maps\ and comment out only line 42.
_loadout is compiled into your mapname_patch, so if you havent recompiled that it still grabs the old version from there. Add it to your mod and edit it to fix the error, then it overwrite's the one that's in your _patch

Turns out it was a memory limit issue that only occurred on some compiles and not others. Fixed it by removing assets and such.
Last Edit: May 21, 2016, 07:26:16 am by Psych

 

Login

or login with an authentication provider below
Sign In with Google
Sign In with Twitter
Sign In with Discord
Sign In with Steam
Sign In with Facebook
Sign In with Twitch
Loading ...