Play the sound when the player passing certain area

broken avatar :(
Created 1389 days ago
by Wolfplayer
0 Members and 1 Guest are viewing this topic.
991 views
broken avatar :(
×
broken avatar :(
Location: ruMoscow
Date Registered: 21 March 2016
Last active: 255 days ago
Posts
30
Respect
Forum Rank
Legless Crawler
Primary Group
Member
My Contact & Social Links
More
Personal Quote
RTCW Modder
×
Wolfplayer's Groups
So I created a trigger_multiple. Made it trigger_once and clientside_trigger.
After that I created script_struct with KVP script_sound.
After that I selected my trigger and then selected script_struct and pressed "w".
But the sound is not working in the game when I am passing trigger_multiple area.
Am I doing something wrong?
broken avatar :(
×
broken avatar :(
Location: br
Date Registered: 20 April 2016
Last active: 67 days ago
Posts
145
Respect
Forum Rank
Pack-a-Puncher
Primary Group
Member
My Contact & Social Links
More
Personal Quote
if I surprised you, you had underestimated me
Signature
if I surprised you, it was because you underestimated me
×
Doodles_Inc's Groups
Doodles_Inc's Contact & Social LinksdoodlescriminoserDoodles_IncDoodlesInc
Yes, you shouldn't use a script_struct and yes use a sound looper.
 :-\
broken avatar :(
×
broken avatar :(
Location: ruMoscow
Date Registered: 21 March 2016
Last active: 255 days ago
Posts
30
Respect
Forum Rank
Legless Crawler
Primary Group
Member
My Contact & Social Links
More
Personal Quote
RTCW Modder
×
Wolfplayer's Groups
I got the sound working, but it does not depends on trigger, it is just playing.
And simply connecting them with "W" key is doing nothing. Can anyone provide an example of simple sound, that activates by multiple_trigger (only once).

 

Login

or login with an authentication provider below
Sign In with Google
Sign In with Twitter
Sign In with Discord
Sign In with Steam
Sign In with Facebook
Sign In with Twitch
Loading ...