sound issues

broken avatar :(
Created 159 days ago
by InZomniac
0 Members and 1 Guest are viewing this topic.
454 views
broken avatar :(
×
broken avatar :(
Location: usPennsylvania
Date Registered: 3 July 2019
Last active: 151 days ago
Posts
8
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
InZomniac's Groups
InZomniac's Contact & Social Links
okay so i been working on a sound EE and after about a month of research trial and error i got the code in the gsc functioning only problem is when i comlete the egg my sound doesnt play now im not sure if it has to do with how im calling the code in the gsc or if it is the csv i coverted the song to mono removed tags converted it in launcher copied that file from raw sounds to mods i used the header from asylum for the csv and took the mx_egg line and edited it to match my sound alias i personally am leaning to it being a csv issue as all the gsc code works just not the playSound part so here these are the scripts also i have the song in mods/mapname/Song and in the raw/sounds/Song and again in sound_assets/Song i just don't understand what i am doing wrong 
not_egg_finished()
{
player = getplayers();
iPrintLnBold("You Moron, You Ruined My Plans!!");
player playSound("MITH");
}
//now the sound alias code
name,file,platform,sequence,vol_min,vol_max,dist_min,dist_max,limit_count,limit_type,entity_limit_count,entity_limit_type,bus,volume_min_falloff_curve,volumefalloffcurve,reverb_send,dist_reverb_max,reverb_min_falloff_curve,reverb_falloff_curve,pitch_min,pitch_max,randomize_type,spatialized,type,probability,loop,masterslave,loadspec,subtitle,compression,secondaryaliasname,chainaliasname,startdelay,speakermap,lfe percentage,center percentage,envelop_min,envelop_max,envelop percentage,occlusion_level,occlusion_wet_dry,real_delay,distance_lpf,move_type,move_time,min_priority,max_priority,min_priority_threshold,max_priority_threshold,,isbig


MITH,Song\MITH.wav,,,0.42,0.42,,,,,,,full_vol,,,0,,,,,,,2d,streamed,,,,,,,,,,music_all,,,,,,0,,,,,,100,100,0.25,1,,
broken avatar :(
×
broken avatar :(
Location: nl
Date Registered: 20 September 2013
Last active: 20 hours ago
Posts
359
Respect
Forum Rank
Perk Hacker
Primary Group
Community Scripter
×
gympie6's Groups
Community Scripter Has shown effort and knowledge in the area of scripting while being a part of the UGX-Mods community.
gympie6's Contact & Social LinksDistenc5Teffrie
okay so i been working on a sound EE and after about a month of research trial and error i got the code in the gsc functioning only problem is when i comlete the egg my sound doesnt play now im not sure if it has to do with how im calling the code in the gsc or if it is the csv i coverted the song to mono removed tags converted it in launcher copied that file from raw sounds to mods i used the header from asylum for the csv and took the mx_egg line and edited it to match my sound alias i personally am leaning to it being a csv issue as all the gsc code works just not the playSound part so here these are the scripts also i have the song in mods/mapname/Song and in the raw/sounds/Song and again in sound_assets/Song i just don't understand what i am doing wrong
not_egg_finished()
{
player = getplayers();
iPrintLnBold("You Moron, You Ruined My Plans!!");
player playSound("MITH");
}
//now the sound alias code
name,file,platform,sequence,vol_min,vol_max,dist_min,dist_max,limit_count,limit_type,entity_limit_count,entity_limit_type,bus,volume_min_falloff_curve,volumefalloffcurve,reverb_send,dist_reverb_max,reverb_min_falloff_curve,reverb_falloff_curve,pitch_min,pitch_max,randomize_type,spatialized,type,probability,loop,masterslave,loadspec,subtitle,compression,secondaryaliasname,chainaliasname,startdelay,speakermap,lfe percentage,center percentage,envelop_min,envelop_max,envelop percentage,occlusion_level,occlusion_wet_dry,real_delay,distance_lpf,move_type,move_time,min_priority,max_priority,min_priority_threshold,max_priority_threshold,,isbig


MITH,Song\MITH.wav,,,0.42,0.42,,,,,,,full_vol,,,0,,,,,,,2d,streamed,,,,,,,,,,music_all,,,,,,0,,,,,,100,100,0.25,1,,
I think I see what the problem is.
You are trying to play a sound on players but the function only works on one player.
This is what you have to do:
players = Getplayers();

for(i = 0; i < players.size; i++)
{
     players[i] playsound("MITH");
     players[i] iPrintLnBold("You Moron, You Ruined My Plans!!");
}
 
Last Edit: July 04, 2019, 05:43:12 pm by gympie6
broken avatar :(
×
broken avatar :(
Location: usPennsylvania
Date Registered: 3 July 2019
Last active: 151 days ago
Posts
8
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
InZomniac's Groups
InZomniac's Contact & Social Links
okay ill give that a try and let you know what happens

broken avatar :(
×
broken avatar :(
Location: usPennsylvania
Date Registered: 3 July 2019
Last active: 151 days ago
Posts
8
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
InZomniac's Groups
InZomniac's Contact & Social Links
it didnt work i have to be doing something wrong here  i tried putting the for and getplayers outside of the function too and nothing now the text doesnt even display 
not_egg_finished()
{
           players = getPlayers();   
for(i = 0; i < players.size; i++)
 
  players[i] playsound("MITH");
     players[i] iPrintLnBold("You Moron, You Ruined My Plans!!");

}
broken avatar :(
×
broken avatar :(
Location: usPennsylvania
Date Registered: 3 July 2019
Last active: 151 days ago
Posts
8
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
InZomniac's Groups
InZomniac's Contact & Social Links
i fixed it but still no music when i do the egg but the for works fine now
broken avatar :(
×
broken avatar :(
Location: nl
Date Registered: 20 September 2013
Last active: 20 hours ago
Posts
359
Respect
Forum Rank
Perk Hacker
Primary Group
Community Scripter
My Groups
More
My Contact & Social Links
More
Personal Quote
I love skulls
×
gympie6's Groups
Community Scripter Has shown effort and knowledge in the area of scripting while being a part of the UGX-Mods community.
gympie6's Contact & Social LinksDistenc5Teffrie
i fixed it but still no music when i do the egg but the for works fine now
Alright that's a good start.

For the steps I will place basic pictures about how to add the soundeffect.







This is what I did for example about adding the PlaneOver soundeffect, maybe you missed one of three parts?
Also don't forget to the soundeffect and add the soundallias. (sound,yourSoundAllias,,all_sp)

I hope this helps. :)
Last Edit: July 18, 2019, 11:15:13 pm by gympie6
broken avatar :(
×
broken avatar :(
Location: usPennsylvania
Date Registered: 3 July 2019
Last active: 151 days ago
Posts
8
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
InZomniac's Groups
InZomniac's Contact & Social Links
i have it like this duno if this is wrong it was from a tutorial on YT 
//The Egg Has Been Completed So Now Do Something
not_egg_finished()
{
           players = getPlayers();   
for(i = 0; i < players.size; i++)
  {
  players[i] playSound("MITH");
     players[i] iPrintLnBold("You Moron, You Ruined My Plans!!");
}
}




this is the working code 
name,file,platform,sequence,vol_min,vol_max,dist_min,dist_max,limit_count,limit_type,entity_limit_count,entity_limit_type,bus,volume_min_falloff_curve,volumefalloffcurve,reverb_send,dist_reverb_max,reverb_min_falloff_curve,reverb_falloff_curve,pitch_min,pitch_max,randomize_type,spatialized,type,probability,loop,masterslave,loadspec,subtitle,compression,secondaryaliasname,chainaliasname,startdelay,speakermap,lfe percentage,center percentage,envelop_min,envelop_max,envelop percentage,occlusion_level,occlusion_wet_dry,real_delay,distance_lpf,move_type,move_time,min_priority,max_priority,min_priority_threshold,max_priority_threshold,,isbig

MITH,Song\MITH.wav,,,1,1,,,,,,,full_vol,,,0,,,,,,,2d,streamed,,,,,,,,,,music_all,,,,,,0,,,,,,100,100,0.25,1,,
sound alias
// Zombie Mode Stuff
include,zombiemode
include,zombiemode_dogs
// Zombie Mode Strings
localize,zombie
// Mod Strings
localize,mod
// Edited Loadout For Zombie Heroes
rawfile,maps\_loadout.gsc
// Edited LastStand For Deep Water Like Sumpf
rawfile,maps\_laststand.gsc
// Edited For Developer_Script
rawfile,maps\_debug.gsc
// Updated Menu File For Pause Screen Map
menufile,ui/objective_info.menu
stringtable,maps/mapsTable.csv
sound,Song\MITH
i have it like this ill try with (all_sp) i did it with (all_mp) before and that didnt work for me either 
could the sound not be converting right or something i used audacity newest version i believe and coverted to unsigned 8 bit pcm and removed tags as directed
broken avatar :(
×
broken avatar :(
Location: nl
Date Registered: 20 September 2013
Last active: 20 hours ago
Posts
359
Respect
Forum Rank
Perk Hacker
Primary Group
Community Scripter
My Groups
More
My Contact & Social Links
More
Personal Quote
I love skulls
×
gympie6's Groups
Community Scripter Has shown effort and knowledge in the area of scripting while being a part of the UGX-Mods community.
gympie6's Contact & Social LinksDistenc5Teffrie
i have it like this duno if this is wrong it was from a tutorial on YT
//The Egg Has Been Completed So Now Do Something
not_egg_finished()
{
           players = getPlayers();   
for(i = 0; i < players.size; i++)
  {
  players[i] playSound("MITH");
     players[i] iPrintLnBold("You Moron, You Ruined My Plans!!");
}
}




this is the working code
name,file,platform,sequence,vol_min,vol_max,dist_min,dist_max,limit_count,limit_type,entity_limit_count,entity_limit_type,bus,volume_min_falloff_curve,volumefalloffcurve,reverb_send,dist_reverb_max,reverb_min_falloff_curve,reverb_falloff_curve,pitch_min,pitch_max,randomize_type,spatialized,type,probability,loop,masterslave,loadspec,subtitle,compression,secondaryaliasname,chainaliasname,startdelay,speakermap,lfe percentage,center percentage,envelop_min,envelop_max,envelop percentage,occlusion_level,occlusion_wet_dry,real_delay,distance_lpf,move_type,move_time,min_priority,max_priority,min_priority_threshold,max_priority_threshold,,isbig

MITH,Song\MITH.wav,,,1,1,,,,,,,full_vol,,,0,,,,,,,2d,streamed,,,,,,,,,,music_all,,,,,,0,,,,,,100,100,0.25,1,,
sound alias
// Zombie Mode Stuff
include,zombiemode
include,zombiemode_dogs
// Zombie Mode Strings
localize,zombie
// Mod Strings
localize,mod
// Edited Loadout For Zombie Heroes
rawfile,maps\_loadout.gsc
// Edited LastStand For Deep Water Like Sumpf
rawfile,maps\_laststand.gsc
// Edited For Developer_Script
rawfile,maps\_debug.gsc
// Updated Menu File For Pause Screen Map
menufile,ui/objective_info.menu
stringtable,maps/mapsTable.csv
sound,Song\MITH
i have it like this ill try with (all_sp) i did it with (all_mp) before and that didnt work for me either
could the sound not be converting right or something i used audacity newest version i believe and coverted to unsigned 8 bit pcm and removed tags as directed
The last one is wrong.
You have to add your soundallias file to the modbuilder not your song.

--------------------------------------------------
Last Edit: July 08, 2019, 07:55:20 pm by gympie6
broken avatar :(
×
broken avatar :(
Location: usPennsylvania
Date Registered: 3 July 2019
Last active: 151 days ago
Posts
8
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
InZomniac's Groups
InZomniac's Contact & Social Links
sound,MITH,,all_sp
so it should look like this right
sound,aliasHERE,,all_sp
also my song file and folder show up in modbuilder and is checked won't let me upload the screenshot without a url link im not wasting my time uploading it i dont use "social media" so i have nowhere to dump it anyway but its all showing up and is ticked but still nothing there has to be something im just not understanding about all this
dosent have to be
sound,folder/alias,,all_sp in the mod csv

Double Post Merge: July 09, 2019, 01:19:38 am
also when i do finally get this working if i ever do lol how would i go about adding more sounds to the alias to be used will it just play all the sounds when the egg is done or can indivual sounds be called like say i added some sound fx to the mix later using asylum as a reference there are all the sounds fx and music in the csv is there a way to do this kind of thing without it just randomly playing them all i know im probably a pain in the rear but i dont get the whole csv thing i can code c++ okay but other things like csv and csc whatnot i dont really get 

as i mintioned before i used the header from asylum csv and for the egg i copied the mx_egg line and modifyed it to match my alias and folder location
Last Edit: July 09, 2019, 01:19:38 am by InZomniac
broken avatar :(
×
broken avatar :(
Location: nl
Date Registered: 20 September 2013
Last active: 20 hours ago
Posts
359
Respect
Forum Rank
Perk Hacker
Primary Group
Community Scripter
My Groups
More
My Contact & Social Links
More
Personal Quote
I love skulls
×
gympie6's Groups
Community Scripter Has shown effort and knowledge in the area of scripting while being a part of the UGX-Mods community.
gympie6's Contact & Social LinksDistenc5Teffrie
sound,MITH,,all_sp
so it should look like this right
sound,aliasHERE,,all_sp
also my song file and folder show up in modbuilder and is checked won't let me upload the screenshot without a url link im not wasting my time uploading it i dont use "social media" so i have nowhere to dump it anyway but its all showing up and is ticked but still nothing there has to be something im just not understanding about all this
dosent have to be
sound,folder/alias,,all_sp in the mod csv

Double Post Merge: July 09, 2019, 01:19:38 am

also when i do finally get this working if i ever do lol how would i go about adding more sounds to the alias to be used will it just play all the sounds when the egg is done or can indivual sounds be called like say i added some sound fx to the mix later using asylum as a reference there are all the sounds fx and music in the csv is there a way to do this kind of thing without it just randomly playing them all i know im probably a pain in the rear but i dont get the whole csv thing i can code c++ okay but other things like csv and csc whatnot i dont really get
as i mintioned before i used the header from asylum csv and for the egg i copied the mx_egg line and modifyed it to match my alias and folder location
 Ok
broken avatar :(
×
broken avatar :(
Location: usPennsylvania
Date Registered: 3 July 2019
Last active: 151 days ago
Posts
8
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
InZomniac's Groups
InZomniac's Contact & Social Links
i finally fixed it it turns out the line i used from asylum mx_egg was wrong in some way i used the line for toilet flush and it worked so the csv was the issue thanks for the help man can't wait to finish the map 
broken avatar :(
×
broken avatar :(
Location: nl
Date Registered: 20 September 2013
Last active: 20 hours ago
Posts
359
Respect
Forum Rank
Perk Hacker
Primary Group
Community Scripter
My Groups
More
My Contact & Social Links
More
Personal Quote
I love skulls
×
gympie6's Groups
Community Scripter Has shown effort and knowledge in the area of scripting while being a part of the UGX-Mods community.
gympie6's Contact & Social LinksDistenc5Teffrie
i finally fixed it it turns out the line i used from asylum mx_egg was wrong in some way i used the line for toilet flush and it worked so the csv was the issue thanks for the help man can't wait to finish the map
 Glad to hear you fixed the issue! Goodjob!! :)

 

Login

or login with an authentication provider below
Sign In with Google
Sign In with Twitter
Sign In with Discord
Sign In with Steam
Sign In with Twitch
Loading ...