Problems with zombie's movement

broken avatar :(
Created 21 days ago
by Pappinator97
0 Members and 1 Guest are viewing this topic.
72 views
broken avatar :(
×
broken avatar :(
Location: it
Date Registered: 27 March 2016
Last active: 3 days ago
Posts
9
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
Pappinator97's Groups
Pappinator97's Contact & Social Links
Hello guys. I'm working on a new Zombie Map and all seemed to work fine. Until I had some problems with the zombies finding the player.
This is the layer of my map:



Zombies doesn't have any problems to find or follow the player when I buy the doors to PathB_1 or PathA_1, and I change area (for example, to PathA_1 to Start_Zone). But, if I buy, for example, the door to PathA_2, all the Zombies in the area PathA_1 and below freezes and stops to moving. Zombies in the area PathA_2 will continue to spawn and find the player normally, but the others in PathA_1 stay blocked and do nothing. This also happens when I change zone to PathA_2 to PathA_1, or some other areas. When I change area, the zombies in the area PathA_2 stops to moving. This happens to ALL the areas of my map, except for Start_Zone, PathA_1, and PathB_1.



They simply freeze and do nothing. 



This is the area declaration on the Mapname.gsc. Note that "percorso" simply means "Path" in Italian.
What could the problem be caused by? It's a declaration area problem, or a Pathnode problem? Thank you for the help!
broken avatar :(
×
broken avatar :(
Location: nl
Date Registered: 20 September 2013
Last active: 6 days ago
Posts
338
Respect
Forum Rank
Perk Hacker
Primary Group
Community Scripter
×
gympie6's Groups
Community Scripter Has shown effort and knowledge in the area of scripting while being a part of the UGX-Mods community.
gympie6's Contact & Social LinksDistenc5Teffrie
Hello guys. I'm working on a new Zombie Map and all seemed to work fine. Until I had some problems with the zombies finding the player.
This is the layer of my map:

( [You are not allowed to view external links. Register or Login to see them] .)

Zombies doesn't have any problems to find or follow the player when I buy the doors to PathB_1 or PathA_1, and I change area (for example, to PathA_1 to Start_Zone). But, if I buy, for example, the door to PathA_2, all the Zombies in the area PathA_1 and below freezes and stops to moving. Zombies in the area PathA_2 will continue to spawn and find the player normally, but the others in PathA_1 stay blocked and do nothing. This also happens when I change zone to PathA_2 to PathA_1, or some other areas. When I change area, the zombies in the area PathA_2 stops to moving. This happens to ALL the areas of my map, except for Start_Zone, PathA_1, and PathB_1.

( [You are not allowed to view external links. Register or Login to see them] .)( [You are not allowed to view external links. Register or Login to see them] .)

They simply freeze and do nothing.

( [You are not allowed to view external links. Register or Login to see them] .)

This is the area declaration on the Mapname.gsc. Note that "percorso" simply means "Path" in Italian.
What could the problem be caused by? It's a declaration area problem, or a Pathnode problem? Thank you for the help!
I need more information about the triggers in radiant because you need them at both the sides of the door with the right script_flag.
and the names of the "enter" zones are very confusing. They are switched?

I mean "pathA2" is going to enter "pathA1" but still is going to move from "pathA1" to "PathA2". ( "enter_percorsoA1A2_zone" );
So it looks like there are problems with using the right names?


What I did for example is giving every zone it's own name and every direction it can go too.
This is better for me to setup and understand.

Last Edit: August 29, 2019, 10:23:54 pm by gympie6

 

Login

or login with an authentication provider below
Sign In with Google
Sign In with Twitter
Sign In with Discord
Sign In with Steam
Sign In with Twitch
Loading ...