Custom weapons not showing in the box (Solved)

broken avatar :(
Created 278 days ago
by OwenC
0 Members and 1 Guest are viewing this topic.
479 views
broken avatar :(
×
broken avatar :(
Location: gb
Date Registered: 14 January 2017
Last active: 59 days ago
Posts
48
Respect
Forum Rank
Legless Crawler
Primary Group
Member
My Contact & Social Links
More
Signature
×
OwenC's Groups
Anyone know what im doing wrong?

when i add a custom weapon it doesn't show up in the box

ive added this to _zombiemode_weapons.gsc
// Custom Weapons
add_zombie_weapon( "csgo_awp", &"ZOMBIE_WEAPON_COLT_50", 50, "vox_crappy", 8 );

and this to dlc3_code.gsc
// Custom Weapons
include_weapon( "csgo_awp" );
include_weapon( "csgo_awp_upgraded", false );

Ive also added all the needed files to my mod folder
Images, sounds, and the weapons.

Last Edit: January 12, 2018, 05:37:15 am by OwenC
broken avatar :(
×
broken avatar :(
Location: ph
Date Registered: 22 May 2016
Last active: 12 days ago
Posts
216
Respect
Forum Rank
Mr. Elemental
Primary Group
Member
Personal Quote
ԅ(≖‿≖ԅ)
×
KhelMho's Groups
KhelMho's Contact & Social Links
everything is good. are you talking about the worldmodel?
make sure the weaponfile is correct in your mod.csv

// Custom Weapon
weapon,sp/csgo_awp
Last Edit: January 10, 2018, 10:23:59 am by KhelMho
broken avatar :(
×
broken avatar :(
Location: gb
Date Registered: 14 January 2017
Last active: 59 days ago
Posts
48
Respect
Forum Rank
Legless Crawler
Primary Group
Member
My Contact & Social Links
More
×
OwenC's Groups
its just not showing in the box for some reason, i can give my self it via the console :/

its doing this with all the weapons i add i have no idea why
broken avatar :(
×
broken avatar :(
Location: ph
Date Registered: 22 May 2016
Last active: 12 days ago
Posts
216
Respect
Forum Rank
Mr. Elemental
Primary Group
Member
Personal Quote
ԅ(≖‿≖ԅ)
×
KhelMho's Groups
KhelMho's Contact & Social Links
when you build the mod, is there some error?
broken avatar :(
×
broken avatar :(
Location: gb
Date Registered: 14 January 2017
Last active: 59 days ago
Posts
48
Respect
Forum Rank
Legless Crawler
Primary Group
Member
My Contact & Social Links
More
×
OwenC's Groups
No its all fine
broken avatar :(
×
broken avatar :(
Location: ph
Date Registered: 22 May 2016
Last active: 12 days ago
Posts
216
Respect
Forum Rank
Mr. Elemental
Primary Group
Member
Personal Quote
ԅ(≖‿≖ԅ)
×
KhelMho's Groups
KhelMho's Contact & Social Links
strange  :poker:
broken avatar :(
×
broken avatar :(
Location: gb
Date Registered: 14 January 2017
Last active: 59 days ago
Posts
48
Respect
Forum Rank
Legless Crawler
Primary Group
Member
My Contact & Social Links
More
×
OwenC's Groups
IKR
broken avatar :(
×
broken avatar :(
Location: fi
Date Registered: 25 June 2013
Last active: 1 day ago
Posts
3,975
Respect
Forum Rank
Eviscerator
Primary Group
UGX V.I.P.
My Groups
More
×
HitmanVere's Groups
Donator ♥ Benevolent Soul who has our eternal gratitude and exclusive access to betas and the donator section of the forum.
UGX V.I.P.
UGX V.I.P.
Community Mapper Has released one or more maps to the UGX-Mods community which have been added to the UGX Map Manager.
BO3 Modtools Alpha
BO3 Modtools Alpha
This user has access to the Black Ops 3 Modtools Alpha
HitmanVere's Contact & Social Links
Try adding true in dlc3_code.gsc for non-upgraded, I somewhat remember that being issue at least for me back in WaW when I made maps there. Like this:
include_weapon( "xr2", true );
broken avatar :(
  • DeletedUser
  • Deleted Member
×
broken avatar :(
DeletedUser
User
Date Registered: N/A
Last active: N/A
Posts
N/A
Respect
Primary Group
Deleted Member
×
DeletedUser's Groups
DeletedUser's Contact & Social Links
Sounds really stupid but, do you added the dlc3_code.gsc and _zombiemode_weapons.gsc to your mod and also selected them? To add a weapon you have to go to init_weapons and include_weapons in _zombiemode_weapons.gsc and dlc3_code.gsc respectively. Now if you have already did that, and the weapon doesn't show in game, maybe in the weapon file the viewmodel it is not asigned, even maybe the viewmodel does not exist. The folder where the weapons are installed is weapons/sp, also ensure that you have your weapon in the mod.csv. Also maybe you have to remove some weapons to make that weapon appear into the box.
broken avatar :(
×
broken avatar :(
Location: gb
Date Registered: 14 January 2017
Last active: 59 days ago
Posts
48
Respect
Forum Rank
Legless Crawler
Primary Group
Member
My Contact & Social Links
More
×
OwenC's Groups
I fixed the issue. I was using UGX 2.0.1 beta script placer but i tried script placer z and it fixed all the issues i had.

 
Loading ...