Script Runtime Error

broken avatar :(
Created 33 days ago
by ERAWEX
0 Members and 1 Guest are viewing this topic.
79 views
broken avatar :(
×
broken avatar :(
Location: ch
Date Registered: 28 March 2017
Last active: 7 hours ago
Posts
16
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
ERAWEX's Groups
ERAWEX's Contact & Social Links
Hi,

While adding a new weapon to one of my maps I ran into a script runtime error.

while compiling it gives me this error:
ERROR: xmodel 'dempsey_viewhands' not found
    failed loading xmodel 'dempsey_viewhands' for asset 'sp/mortar_strike' found in source file '../zone_source/mod.csv'
    failed loading 'dempsey_viewhands' of type 'xmodel' found in source file '../zone_source/mod.csv'
    failed loading 'sp/mortar_strike' of type 'weapon' found in source file '../zone_source/mod.csv'

When compiling is finished it tells me that there is a script runtime error and that it cannot find the item "mortar_strike" or the weapon itself.

Would anyone know what's wrong?

ERAWEX

This is the console:  [You are not allowed to view external links. Register or Login to see them]
broken avatar :(
×
broken avatar :(
Location: alDurrës
Date Registered: 6 June 2017
Last active: 7 days ago
Posts
138
Respect
Forum Rank
Pack-a-Puncher
Primary Group
Member
My Groups
More
My Contact & Social Links
More
Signature
i am the issue
×
klevi's Groups
Donator ♥ Benevolent Soul who has our eternal gratitude and exclusive access to betas and the donator section of the forum.
Make sure you're correctly following whatever tutorial you're actually following, and if i am not wrong, runtimes migt also be caused because you're running your map with devmap, so just try to normal run  it from the console, map mapname.
broken avatar :(
×
broken avatar :(
Location: ch
Date Registered: 28 March 2017
Last active: 7 hours ago
Posts
16
Respect
Forum Rank
Legless Crawler
Primary Group
Member
×
ERAWEX's Groups
ERAWEX's Contact & Social Links
Thank you for your reply.

I am certain that I followed the tutorial correctly. 

Runnign the map normally does get rid of the error itself but the weapon does not appear in the map. I tried to optain it with "give all", or just by spinning the box and so on.

Could it be that I am missing assets? Or that I have added the weapon incorrectly in the _weapon file or dlc3_code file? 

The tutorial does not specify in which way you need to add it to those files.

ERAWEX

 

Login

or login with an authentication provider below
Sign In with Google
Sign In with Twitter
Sign In with Discord
Sign In with Steam
Sign In with Facebook
Sign In with Twitch
Loading ...