Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - ERAWEX

Do you have the "dynamicpath" box ticked on your door?
3 days ago
Hi there,

I have implemented two boss zombies into my map and they both work fine for a certain amout of time. Past round 30/31/32/33 none of them will spawn anymore and I have tried to figure out why but can't find an answer. It seems to not be directly related to the rounds but to the time that has past ingame to get there. Would anyone know whats causing this?

Any help on this issue would be greatly appreciated!
ERAWEX
4 days ago
I don't know if you readed the ugx installer optional options but if you add the bik video at the root of your mod it would be automaticly installed into your friends main video folder.
I was finaly able to try this (sorry that too this long) but it sadly did not work, my friend still only sees the activision loading screen.

So what I did was place the mapname_load.bik into the root/mods/mapname folder and created a new installer with UGX Installer 1.1 and nothing really happen on my friends end. Is there something they need to do manually? or am I just setting this up wrong?




Double Post Merge: May 27, 2020, 03:37:01 pm
I don't know if you readed the ugx installer optional options but if you add the bik video at the root of your mod it would be automaticly installed into your friends main video folder.
 I have now also tried to include the .bik file in "appdata/local/activision/codwaw/mods/mapname" and that also didn't work. Would there be any other way?
5 days ago

oh sorry I will keep it simple:

radios()
{
    // For entities
    radiolist = getEntArray("radio_location", "targetname");
   
    // For structs, uncomment it if you use structs
    // radiolist = GetStructArray("radio_location", "targetname");
   
    for(i = 0; i < radiolist.size; i++)
    {
        radiolist[i] thread play_radio();
    }
}

play_radio(radio)
{
    while(1)
    {
        radio playsound("YOUR-SONG-NAME");
   
        // set here the time that you would like to wait.
        wait randomIntRange(150,300);
    }
   
    // you can also do this instead of using the whileloop
    // radio  playLoopSound ("YOUR-SONG-NAME");
}
You can add both of this at the bottom of your MAPNAME.gsc file
Then scroll up until you see this:
    /*--------------------
     ZOMBIE MODE
    ----------------------*/
    [[level.DLC3.weapons]]();
    [[level.DLC3.powerUps]]();   
    thread maps\dw_fx::init();   
   
    maps\_zombiemode::main();
under that add:
level thread radios();
Yes add entities or structs on the map and use the targetname: radio_location
 So it looks like this:
    /*--------------------
     ZOMBIE MODE
    ----------------------*/
    [[level.DLC3.weapons]]();
    [[level.DLC3.powerUps]]();   
    thread maps\dw_fx::init();   
   
    maps\_zombiemode::main();
   
    level thread radios();
 Oh wow! Thanks for the help man it is very appreciated!
6 days ago
I am not a pro at this kind of stuff but this is how I made looping sound in Snowblind:

radios()
{
    radiolist = getEntArray("radio_location", "targetname");
    for(i = 0; i < radiolist.size; i++)
    {
        radiolist[i] thread play_radio(radiolist[i]);
    }
}

play_radio(radio)
{
    rememberLastSong = -1;
   
    while(1)
    {
        wait randomIntRange(150,300);
       
        rand = randomInt(6);
        if(rand == rememberLastSong)
        rand = randomInt(6);

        rememberLastSong = rand;       
        radioSong = ("radio_song" + rand);
       
        radio playsound(radioSong);   
        wait 200;
    }
}
 Yeah me neither :) Alright how would I go about to impement this? Would the comments in the script be right?
radios() //ADD THIS UNDER ZOMBIEMODE::MAIN IN mapname.gsc?
{
    radiolist = getEntArray("radio_location", "targetname");
    for(i = 0; i < radiolist.size; i++)
    {
        radiolist[i] thread play_radio(radiolist[i]);
    }
}

play_radio(radio) // and then paste this at the end of the .gsc?
{
    rememberLastSong = -1;
   
    while(1)
    {
        wait randomIntRange(150,300);
       
        rand = randomInt(6);
        if(rand == rememberLastSong)
        rand = randomInt(6);

        rememberLastSong = rand;       
        radioSong = ("radio_song" + rand);
       
        radio playsound(radioSong);   
        wait 200;
    }
}

//and then for the radiant part add a trigger with (targetname, radio_location) and then im done? is //that all?
7 days ago
Hello there,

I have added some looping sound emitters to my map and for some reason the sounds are looping in to each other, meaning the sound gets lounder/more agressive until the sound is almost unbearable to hear. Is there a way to just loop the sound how it is like let the sound playout fully and then just play it again?

The sound im using is just shy of 3 seconds long idk if that's important.

Any help would be appreciated.

ERAWEX
7 days ago
I don't know if you readed the ugx installer optional options but if you add the bik video at the root of your mod it would be automaticly installed into your friends main video folder.
 I see, thank you for your advice!
7 days ago
 I took your mod from my mods folder, directly archived it into a .rar, and sent it to him. unpacking it and placing it in the mods folder lets him load the mod, but when he tries to play he is missing a script or something like that.

so even when he gets it installed, it doesn't work.
 Weird.. I am afraid the problem might be your friends pc, since I haven't recived any messages about this error and as far as I know everyone who downloaded the map was able to play it. Maybe ask your friend to re-download it from the link on the main page and try again. 

If the error still occurs send me a message telling me the exact script he is missing or the error that shows.
7 days ago
Hi there,

I have made a solo loading screen for my map and it works perfectly. Now the problem is, if I make a installer and send it to a friend, they don't have the loading screen when they play solo. 

I thinks it's because the loading screen file is located in ROOT/main/videos with all the other .bik files which means it's not included in the mod.

My question is then, is it possible to add the .bik file to the mod so other people who play the map in solo will have the loading screen instead of the standard activision one? 

Thank you for your time.

ERAWEX
8 days ago
Sweet. I look forward to trying 2.0.  I've found a brick on the roof, which I assume is where the weapon is. I tried shooting it, and nothing happened. Am I still shooting things for the easter egg?

Great map btw.
Im assuming we are talking about the same thing, try getting up there. It is possible to get up on the roof through a series of jumps (for people who want to explore the outside of the map). It has something to find up there.

Cheers for that I hope you'll enjoy it!

Double Post Merge: May 24, 2020, 11:48:01 am
 Yes, he has T4M installed in the root folder of COD WAW
 Alright well ive never seen that error befor and tried searching for it on the forum but couldn't find anything on it. I'm sorry it doesn't work, maybe try to run the installer as administrator other then that I can't think of anything else that would help.
8 days ago
I found a nasty glitch. If you jump on the railing by the sofa in the start room then you get stuck and are forced to restart. Once you've restarted you will no longer be able to pick up weapons from the box. 
Thanks for the notice.

Regarding the getting weapons problem,  it occurs when you restart the game or die and restart but it is fixed by just reloading the mod and starting a new game.

Double Post Merge: May 22, 2020, 09:08:24 pm

Map fails to extract, no idea why. Works fine on my computer, but this is my friends computer.
https://i.imgur.com/wzd1dZJ.png
 I have never come across this befor, has your friend downloaded/installed T4M? 

Double Post Merge: May 22, 2020, 09:14:22 pm

So I've been hunting for the easter egg weapons and found two, the ms & the df. I'm looking for a third but can't find anything. I've tried shooting everything with the ms and am not sure if I need to shoot stuff with the df. Is the mortar strike used? Please drop me a hint if you're willing.
I think there is one more in the 1.4 version. Pretty hard to find, I would check the outside and top of the map ;)

But I will be soon releasing another maybe final update "version 2.0" which will have more easter eggs and some great new weapons, areas, redone boss zombie and other additions. 
9 days ago
Worked out great! Thanks.
11 days ago
Hi there,

Im looking to give the player who triggers the trigger a weapon as part of an easter egg. 

I have a script that works but if one player triggers the trigger all players in the game get the weapon. 

eeScript()
{
    eeTrigger = GetEnt("ee_trigger", "targetname");
        eeTrigger waittill("trigger");
        eeTrigger Delete();
        players = get_players();
        for(i=0;i<players.size;i++)
        {
        players[i] GiveWeapon("tesla_gun_upgraded");
        players[i] SwitchToWeapon("tesla_gun_upgraded");
    }
}
Would anyone know how to modify the script in order to only give the weapon to the person/player who triggers the trigger?
Thanks for any help.
ERAWEX
13 days ago
HI there,

I have recently added some custom weapons to two of my maps One test map and one proper map. The sounds and weapon work fine on the test map but on the proper map,
the only the pack a punched version of the weapon is in the map even when using give custom_weapon in consol + no sound of the weapon is in the game.

Ive ticked it in the IWD file list, ive checked the dlc3 code and the _weapons file and they seem good. The soundalias is just the way its sopposed to be since it workes on the test map. Would anyone know why only the PAP version of a gun appears and why theres no sound even though everything else works on other maps?

Thank you for your time any help is appreciated.

ERAWEX
14 days ago
Hey game keeps crashing everytime i try to play it how can i fix
 Have you downloaded and installed T4M?
17 days ago

Login

or login with an authentication provider below
Sign In with Google
Sign In with Twitter
Sign In with Discord
Sign In with Steam
Sign In with Facebook
Sign In with Twitch
Loading ...